home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 05-01-2014, 06:23 PM   #1
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default Loud ticking from injectors

I've known injectors to have a mild ticking sound but this ticking sound can be heard in the cabin of my 240.

Basic specs
93 240, MS3.57 V2, High-Z 80lb Siemen Injectors, 16v head, .50trim SS bullseye turbo

Injectors don't feel hot to the touch as if they are being over current.
__________________
93 245 LS Engine Swap Project
Texas240 is offline   Reply With Quote
Old 05-01-2014, 06:24 PM   #2
Lord_Athlon
300+ Clurb
 
Lord_Athlon's Avatar
 
Join Date: May 2003
Location: Eau Claire, WI.
Default

Batch fire I assume? Ive had injectors I could hear in the cabin as well.
__________________
Quote:
Originally Posted by RvolvoR View Post
simple...just throw the redblock in the trash and install, well, almost anything modern

Quote:
Originally Posted by Harlard View Post
Yet Asher here went with...
Lord_Athlon is offline   Reply With Quote
Old 05-01-2014, 06:25 PM   #3
midnightsaint
Board Member
 
Join Date: Mar 2014
Location: Tulsa
Default

Check your fuel pressure.
__________________
1991 240 bone stock(for now)
adtendite et videte si quis confidit
midnightsaint is offline   Reply With Quote
Old 05-01-2014, 06:42 PM   #4
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default

Quote:
Originally Posted by Lord_Athlon View Post
Batch fire I assume? Ive had injectors I could hear in the cabin as well.
Yep.

Not to come off like an idiot but this car has had some weird noises from various other parts like noisy getrag, noisy throwout bearing and a few other noises from the drive line so I might not be use to loud injectors as the injectors have been masked by other noises. I assume.

Was more of a curious question then anything else and these injectors have maybe 5k miles on them fyi. Everything else is where it needs to be.
Texas240 is offline   Reply With Quote
Old 05-01-2014, 06:43 PM   #5
Lord_Athlon
300+ Clurb
 
Lord_Athlon's Avatar
 
Join Date: May 2003
Location: Eau Claire, WI.
Default

Ride it out. How many pulses/revolution?
Lord_Athlon is offline   Reply With Quote
Old 05-01-2014, 06:52 PM   #6
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default

Quote:
Originally Posted by Lord_Athlon View Post
Ride it out. How many pulses/revolution?
That was the plan. Injector dead time is .900 with a voltage correction of .200
Texas240 is offline   Reply With Quote
Old 05-02-2014, 01:33 PM   #7
jerryc
Board Member
 
jerryc's Avatar
 
Join Date: Jun 2004
Location: SF Bay area
Default

I had a 93 940T that was stock, and the injectors in that car were loud also. I have had 5 T cars, many NA cars, and only this one was this loud. I even swapped the injectors with another car, and the noise stayed with the car. Fuel pressure was measured and was correct. At least 4 fpr's were tried. No difference.
Never did figure it out, now the car is gone.
__________________
Quote:
Originally Posted by Ursan View Post
What's the female equivalent to a dick pic? twat shot?
Quote:
Originally Posted by XxJenoxX View Post
There isn't one because dudes aren't grossed out by unsolicited vaginas.
jerryc is offline   Reply With Quote
Old 05-02-2014, 03:22 PM   #8
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default

Quote:
Originally Posted by jerryc View Post
I had a 93 940T that was stock, and the injectors in that car were loud also. I have had 5 T cars, many NA cars, and only this one was this loud. I even swapped the injectors with another car, and the noise stayed with the car. Fuel pressure was measured and was correct. At least 4 fpr's were tried. No difference.
Never did figure it out, now the car is gone.
Thats seems to be the prognostics. Talked to kenny who had the car for a month last december and apparently it was loud then. I just now noticed. Eh
Texas240 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:18 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.